Arc System Requirements

Arc Prerequisites

Arc is multi-platforms, it supports Windows, Linux and Mac OS.

Arc is officially supported on TM1 11+ (Planning Analytics 2+). Most features will work with TM1 10.2.2 but a number of important APIs are only present in TM1 11+.

The TM1 REST API is required for Arc to work, it can be enabled by setting the HTTPPortNumber parameter in the tm1s.cfg file, i.e. HTTPPortNumber=8111. See: code.cubewise.com/blog/enabling-the-tm1-rest-api.

To enable Turbo Integrator debugging you must also add EnableTIDebugging to the tm1s.cfg file, i.e. EnableTIDebugging =true You need to restart the TM1 service for these settings to take effect.

Server Configuration

Arc supports all TM1 security modes that require a password, Windows Authentication and CAM Single Sign On is not supported at this stage.

Web Browser

  • Internet Explorer 10+

  • Any other modern browser: Firefox, Chrome, Safari, etc.